Get in touch
Back
Maintenance

Emergency Maintence

Completed 5 Oct at 01:18pm BST.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 5 Oct at 01:18pm BST.
Started

We are currently performing an emergency update due fix a issue with our tournament finder system.

Posted 5 Oct at 01:08pm BST.