Get in touch
Back
Maintenance

Affiliate Software Update

Completed 13 Oct at 02:05pm BST.

The Fedr8tion Affiliate
Completed

Maintenance completed

Posted 13 Oct at 02:05pm BST.
Started

We are updating our affiliate servers and may result is a temporarily reduced user experience.

Posted 13 Oct at 02:00pm BST.