Get in touch
Back
Maintenance

FedR8tion Weekly Maintenance

Completed 17 Oct at 05:30pm BST.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 17 Oct at 05:30pm BST.
Started

We will be updating our live platform with our Duels update and other fixes at this time.

Posted 17 Oct at 05:00pm BST.