Get in touch
Back
Maintenance

FedR8tion Quick Maintenance

Completed 20 Oct at 12:00am BST.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 20 Oct at 12:00am BST.
Started

We are updated the main FedR8tion servcies to resolve an issue when searching for other players on the service.

Posted 19 Oct at 11:50pm BST.