Back
Maintenance
Maintenance
FedR8tion Software Update
Completed 20 Oct at 10:50pm BST.
The FedR8tion
Public API Endpoint
Tournaments
Payouts
Directory & Rankings
Completed
Maintenance completed
Posted
20 Oct at 10:50pm BST.
Started
We are performing planned maintenance for our software with an update to match management and other fixes.
Posted
20 Oct at 10:45pm BST.