Get in touch
Back
Maintenance

Affiliate Software Update

Completed 25 Oct at 12:55pm BST.

The Fedr8tion Affiliate
Completed

Maintenance completed

Posted 25 Oct at 12:55pm BST.
Started

We are updating our affiliate systems to allow better tracking for affiliates and our partners.

Posted 25 Oct at 12:45pm BST.