Get in touch
Back
Maintenance

FedR8tion Weekly Update

Completed 25 Oct at 05:55pm BST.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 25 Oct at 05:55pm BST.
Started

We are performing maintenance on our systems to update our software with new features. The downtime will be minimal

Posted 25 Oct at 05:45pm BST.