Get in touch
Back
Maintenance

FedR8tion Full Update

Completed 28 Oct at 12:10pm BST.

The FedR8tion The Fedr8tion Affiliate Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 28 Oct at 12:10pm BST.
Started

We are launching an update on all our platforms for the launch of our new Affiliate Season. This update will be for a short period of time

Posted 28 Oct at 12:00pm BST.