Get in touch
Back
Maintenance

FedR8tion Weekly Maintenance

Completed 3 Nov at 05:20pm GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 3 Nov at 05:20pm GMT.
Started

Brief maintainence to update our blog systems and implement minor fixes across the site.

Posted 3 Nov at 04:35pm GMT.