Get in touch
Back
Maintenance

FedR8tion Weekly Maintenance

Completed 14 Nov at 11:45pm GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 14 Nov at 11:45pm GMT.
Started

We are performing maintenance on our systems to update our management systems.

Posted 14 Nov at 10:30pm GMT.