Back
Maintenance
Maintenance
FedR8tion Software Update
Completed 16 Nov at 09:10am GMT.
The FedR8tion
Public API Endpoint
Tournaments
Payouts
Directory & Rankings
Completed
Maintenance completed
Posted
16 Nov at 09:10am GMT.
Started
A quick update this morning to resolve issues with tournament refunds.
Posted
16 Nov at 09:00am GMT.