Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 18 Nov at 07:10pm GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 18 Nov at 07:10pm GMT.
Started

We are updating our software in preparation for event streams next week.

Posted 18 Nov at 06:55pm GMT.