Back
Maintenance
Maintenance
FedR8tion Software Update
Completed 25 Nov at 12:05pm GMT.
The FedR8tion
Public API Endpoint
Tournaments
Payouts
Directory & Rankings
Completed
Maintenance completed
Posted
25 Nov at 12:05pm GMT.
Started
Software Update
Posted
25 Nov at 11:55am GMT.