Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 14 Dec at 08:15pm GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 14 Dec at 08:15pm GMT.
Started

We are performing a software update to our core services. This update will bring new features to the site.

Posted 14 Dec at 07:55pm GMT.