Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 5 Jan at 09:50am GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 5 Jan at 09:50am GMT.
Started

We are briefing updating our systems.

Posted 5 Jan at 09:40am GMT.