Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 9 Jan at 01:20pm GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 9 Jan at 01:20pm GMT.
Started

We are implementing a minor update for features missing from our previous update.

Posted 9 Jan at 01:10pm GMT.