Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 9 Jan at 05:10pm GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 9 Jan at 05:10pm GMT.
Started

We are performing unexpected maintenance to add an important feature required for tournaments.

Posted 9 Jan at 05:00pm GMT.