Back
Maintenance
Maintenance
FedR8tion Weekly Maintenance
Completed 12 Jan at 10:40am GMT.
The FedR8tion
Public API Endpoint
Tournaments
Payouts
Directory & Rankings
Completed
Maintenance completed
Posted
12 Jan at 10:40am GMT.
Started
We are updating our software to resolve issues relating to blog rendering on mobile.
Posted
12 Jan at 10:30am GMT.