Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 30 Jan at 02:40pm GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 30 Jan at 02:40pm GMT.
Started

We are updating our software with fixes relating to content pushed this morning.

Posted 30 Jan at 02:30pm GMT.