Back
Maintenance
Maintenance
FedR8tion Software Update
Completed 1 Feb at 09:05am GMT.
The FedR8tion
Public API Endpoint
Tournaments
Payouts
Directory & Rankings
Completed
Maintenance completed
Posted
1 Feb at 09:05am GMT.
Started
We are updating our systems to include a new chat for tournament participants.
Posted
1 Feb at 08:55am GMT.