Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 20 Feb at 09:35am GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 20 Feb at 09:35am GMT.
Started

We are updating our systems to implement new and exciting systems for tournaments.

Posted 20 Feb at 09:25am GMT.