Get in touch
Back
Maintenance

FedR8tion Software Update

Completed 21 Feb at 10:10am GMT.

The FedR8tion Public API Endpoint Tournaments Payouts Directory & Rankings
Completed

Maintenance completed

Posted 21 Feb at 10:10am GMT.
Started

We are briefly updating our systems to include better access to our partnership programme.

Posted 21 Feb at 10:00am GMT.